HOW TO: Reduce the number of emails that the Ketogenic Forums send me


(Richard Morris) #1

Many users like to use email to keep track of what is going on at the Ketogenic Forums. There are two ways to do this, one is to make the server send you notifications of activity related to your account, the other is to use “Mailing list mode”.

You can change these settings from the preferences icon in your user drop down menu.

Mailing list mode allows you to select one of three options:

  1. Send daily updates.
    This just sends one single mail per day. It may be a bit large, but still only one single mail.
  2. Send me an email for every new post (up to 8 per day).
  3. Send me a new email for every new post except my own.

So, how do you reduce the number of emails? Simple: either use option 1. above, or mute the categories which aren’t of interest to you.

As well as the mailing list mode, have a look at the section of your preferences dealing with email notifications, it looks like this.:


I would select “Unless previously sent” and enable:
* Send me an email when someone messages me.
If you HAVEN’T enabled Mailing list mode, then also enable
* Send me an email when someone quotes me, replies to my post, mentions my @username or invites me to a topic.
(otherwise this could double how many mails you get!)


(Chan Cleland) #2

Is there anyway to get no emails?


(Richard Morris) #3

I believe if you uncheck all the options you will get no mail.


(Bill Smit) #4

thank you for that question sir.


(Vanessa) #5

I’ve unchecked everything I can and saved my choices but still receive about 5 emails a day. Anyone else having this problem?


(John Gillaspy) #8

I"m having this issue myself. Really getting tired of 6-8 emails a day when I’ve requested to have none sent. Mods, please fix this.

JG


(Old Baconian) #9

Our apologies, folks. This is an aftereffect of moving the forum to a new Web host, and I have no idea how much longer it will persist. I recommend setting your e-mail to simply divert the troublesome e-mails automatically into trash until the problem is over. I routinely receive over sixty unwanted e-mails a day (used to receive several hundred on my old e-mail address), and I can testify that this greatly aids one’s peace of mind.

The only other alternative is to delete your account.


(Jeremy Wheatley) #10

Omg!! I’m glad I’m not the only one… I’ve tried unchecking all options… I’ve tried unsubscribing… I’ve tried sending them straight to trash… I’ve even tried changing my email… nothing flippin works!! Please fix it soon!!


(Richard Morris) #11

It should be fixed now. We had a consultant manage the migration for us, so we were not actually hands on for the process - so it has been just as frustrating for us.

Before the migration the forum was sending out 5,000 emails a day. For 6 days during the migration it was sending out more than 10x that. It’s currently for the past 2 days been sending out 1,500 emails a day.


#12

Thanks Richard for the update, and apologies to everyone who was affected by this. I know how treasured everyone’s inboxes can be and any unwanted emails, no matter the source, reason, or volume, can be frustrating.

Let the ship sail once more! :ship:


(Anne) #13

I’m so glad I stumbled across this thread! I havent been active here for maybe 8 months and suddenly I was getting forum update emails six times a day, despite unsubscribing over and over. I finally managed to turn off all emails in a fit of frustration. I guess I can turn some back on now!


(Old Baconian) #14

It was quite an ordeal, but is now over. It should be safe to restore your settings.


(Richard Morris) #15

We found out the underlying cause, and once we addressed that, I anticipate the problem will not reappear. The problem was that the system would go through the database every 30 mins looking for people who had not received a digest update and adding them to a queue of people to be notified. Moving to slower hardware meant that that queue was not being cleared in the 30 mins before it was getting filled again - so people were being added multiple times and eventually the queue would be too long and bring everything to it’s knees.

The immediate fix was to increase the 30 mins to 60 mins. But the problem after a few days reappeared. So the guys who built the software looked into the problem and changed the application to only add people to the queue who had not been already added to the queue.

Typical of engineers; when you see problem, stopping the symptom is a lot less satisfying than fixing the underlying problem. When you stop the symptom you never know if the problem may reappear.

It’s an interesting analogy to how we fix diabetes, by lowering glucose (symptom) or lowering insulin (cause). It also explains why guys like Ivor and Dave and Carl and I are doing this.